Pathagoras On Cloud

Quick Overview

Hide Navigation Pane

Quick Overview

Previous topic Next topic No directory for this topic  

Quick Overview

Previous topic Next topic Topic directory requires JavaScript JavaScript is required for the print function Mail us feedback on this topic!  

Overview of Pathagoras On Cloud

   Pathagoras On Cloud, like its sister program 'Pathagoras On Earth' is a plain text based document assembly/document automation program. The primary difference from Pathagoras 'on earth' is that Pathagoras On Cloud is platformless (i.e., it doesn't require a specific platform such as Word to function). The word processing (creation, editing and automation) is handled either on the servers hosting the program or by the functionality of your browser.

 

   For the geeks in the crowd, Pathagoras On Cloud is programmed in HTML, Javascript and ASP, and uses very little of your computer's resources. All the heavy lifting is done by us.

 

   When you log onto the site, you will asked to provide your credentials. These will be the credentials you used when you first signed up for the free trial. After your credentials are accepted, you will be taken to the main ('home') screen.

Main Screen

Click to enlaarge.

   Note the three panels on the main page: Folders, Files and the Assembly catcher.

 

    FOLDERS: The left-most panel is your 'explorer'. From this panel, you can select a folder from which you wish to recall a document. Also, your can organize and reorganize your folder structure. You can create new folders and delete ones you no longer want. You can upload documents from 'earth' and move files already based in the cloud to new locations. Just like you normally do.

   Three 'standard' folders will be present for the newcomer:

 Boilerplate (which contains documents that will be always available when you are editing documents;

 Instant Database (abbreviated IDB), where your client/customer records will be saved for recall; and

 Tutorials (similar to this Manual, but in-program and readily accessible).

 

    FILES: The middle panel of the Main Screen displays documents in the currently selected folder. There are several actions you can take in this panel. You can check one or more documents for further actions; you can select a document; you can double click a document to open it; you can drag a document to the 'catcher' to begin/add to a list of documents you want to assemble. These actions will be discussed further below in this Manual. Playing with the program just a little is all that is needed to become used to the various clicks and actions.

 

    ASSEMBLY CATCHER: The right-most panel is the 'document assembly' panel, designed to receive documents that you slide into the 'catcher.'  (If you select a single document from the middle panel, the 'catcher' will turn into a 'Selected File' menu, the assumption being that you are not assembling multiple documents at the present time.)

__________________________________

 

    Pathagoras on Cloud is optimized for desktop or laptop PCs and Macs. That means standard screens and a mouse for selecting, hovering, selecting and dragging. However, it was built with touch-screen and hand-held devices in mind as well. The buttons and icons are intentionally larger so that you can tap them/drag them with your finger.

   

    With PCs and Macs, you can hover over a button with your mouse to get an explanation of the button's function. This is not possible with handhelds, but after a bit of practice, you should quickly learn what the various icons represent.

 

    Note: 'Selecting' and 'Checking' a file are not the same thing. You 'select' a file by clicking the main body of the file, button, etc. 'Checking' is when you tap/click in the checkbox (when provided). The distinctions between 'selecting' and 'checking' will become clear as you use the program.

 

Create a new document: Click the Create New button above the FILES panel. (If you are currently editing a document, click the File tab and click Create New Document. This will open a new tab in your browser. Both the original and the new document will be editable.)

 clip0001

Create New Doc

Upload documents that reside on your desktop: Select (or create and then select) a folder. Click the Up Arrow (the ‘Upload files’) button in the FILES panel. Navigate to the folder on the local computer that contains your documents. Select the ones you want to upload and click OK. The On Cloud screen will list you selections. Click ‘Upload Files’ to begin the actual transfer. (Note: It is not necessary that any documents be ‘Pathagorized.’ Any document can be uploaded and ‘Pathagorized’ later.)

 clip0002

Upload

‘Edit a document’: Whether a new document or an uploaded document, press the Edit button to begin working on your document. And of course in this context, this is what you will be clicking when you want to Pathagorize your documents. A separate section below, tilted 'The Editing Screen', will discuss this aspect of the program.

 

 clip0003

Edit

Assemble' a document’: Pathagoras allows you a unique drag and drop approach to building documents (or packages of documents) from component parts. With the files on display, use your mouse (or your finger) to drag as many items as you want to the 'file catcher' at the right. Rearrange the files as desired.

Alternatively, you can select (by checking) the items in the center panel that you want to assemble. Move them en masse to the assembly panel by clicking the Add icon.

You can rearrange the order of the documents in the Selection Panel with your mouse or your finger. Just drag and drop.

 
When the document parts you want to assemble are selected, chose whether to assemble on line or download to your computer. (If you need to process the document, and don't have Pathagoras 'On Earth' (you should process in the cloud and download the final product after processing. You will always get a Word document.

clip0004

'Catcher'

 

  clip0005

Add to assembly list

Save the document: Be sure to save your document before testing or production. Press the Save button on the editing screen or the appropriate Save or Save As button in the File tab. (If you plan to add search capabilities to your documents, add a Title, Subject and Author to the document properties section in the right column.

 clip0006

Save

 The Editing Screen and Editor Features

After you have selected a document to edit, or chosen to create a new document, you will be pleased to discover that you are working with a full fledged document editor. It is not 'Word(tm)' but it (combined with the features of Pathagoras) has the tools you will need to create automated documents which will meet your automation objectives. Plus, it is fully conversant with Word. You can insert Word text into the editor and copy and paste from the editor into a Word document.

 

Note the following about the editor:.

Your normal hotkeys work:

Ctrl-C to copy; Ctrl-V to paste; Ctrl-X to cut. Ctrl-B, Ctrl-I and Ctrl-U to bold, italicize and underline selected text.

Alt-S saves the current document; Alt-H closes it (of course giving you the opportunity to save your work up to this point.

You have full Tables creation capabilities (and you might actually find it a little easier to use than Word.

You have Search and Spell Check capabilities. You can insert images, create,edit delete hyperlinks.

Note that there is a 'Read View' and an 'Edit View'. If you are not able to type in the document, check out the Document Mode section of the screen.

If you are simply in need of editing a document, you can stop reading here.

 

However, your goal likely is is to 'Pathagorize' a document for automation purposes. So when you finish this overview, study the Variables and Conditional Text sections of this Manual to learn how to add automation to your documents.

 ACTIVATING YOUR AUTOMATED DOCUMENTS.

Process Options and Optional Text: Click the Pathagoras Tools tab.  (1) Press Alt-P (for 'P'rocess). Pathagoras will scan the document for Options and Optional text blocks and ask questions that those block contain. Make selections as appropriate.

clip0007

Process

Replace Variables with personal text: Click the Pathagoras Tools tab.  (1) Press Alt-D (for Instant Database) to display the Instant Database screen. (2) Click the Scan button near the top of the new screen. The screen will populate with discovered variables. (3) For each variable shown at the left, provide replacement text in space at right. (4) Click ‘Replace’ button. If you wish to save variable to value pairing for reuse in future documents, so indicate.

 clip0008

IDB

 

Post production options: Save processed document in new (client-oriented) folder or mail to yourself or others. Choices are shown in the Files tab.

clip0009

Share

 

Do note that the displays of open documents and explorer tools in the cloud is different from that on earth. When you open a new document, or call a new procedure in the cloud, a new tab at the top your your web navigator is opened. (On earth, the navigator and document references typically appear at the bottom on your screen in icons. In the cloud, they appear near the top as tabs.) So when a screen doesn't change the way you might expect on a PC, check the tabs at the top of your screen.
 

 ======================================================

 Some initial 'get to know the program' exercises

 

    First, familiarize yourself with the screenage. We’ll skip the sign-in screen except to say that the Pathagoras button at the left will take you to the main Pathagoras website and the Contact button should be frequently used whenever you have any questions for us.

   After you type in your credentials, you will see a screen with two panels. The left panel focuses on folder management and the right on files (with the selected folder) management. Briefly scan the various buttons so you become familiar with what you can accomplish.

Pathagorize Document:

The first ‘real’ step in learning Pathagoras On Cloud is create to at least one ‘Pathagorized’ document. Two ways to get you started here:

1.You can start with an existing document that you upload to the cloud.
 

Using the Upload Files box in the right panel (the UP arrow), upload one or more documents to the cloud. We recommend that you start learning Pathagoras with fairly simple documents. Beginning the process with your most complex document will actually slow down the learning curve.

2.Or you can start from a blank slate. To begin a new document On Cloud, click the ‘New Document’icon found at the top right of the screen. From there you can:

type away;

copy and paste text from an existing Word (or other) document; or

copy and paste any text from any other source.

 Once you have some useful text on screen, add a variable or two. At a spot where you want a personal value to eventually be, type a ‘variable sounding’ name (such as Client Name and Spouse Address) and enclose it within simple square brackets. Examples: [Client Name] [Spouse Address]. That's all there is to it! See About Variables.

 You can get a bit fancier by inserting simple optional text markers around text that is not always kept in this particular document. The markers are the curly braces. {So this sentence is now ‘optional’ and when Pathagoras processes the page it will highlight this section and ask “Do you want to keep this text?”}

 Once you have prepared your first document, save it to the system. Standard 'save' buttons exist on the screen for doing so.

       Using Your Pathagorized Document: Recall your Pathagorized document to the screen. Actually, we want you recall a copy of the document. To do so, navigate to it from the ‘home’ screen (or use the Open Document button in the file menu). Select the document you wish to use by clicking on its face. Then click the Document Assembly button. Pathagoras will then call up a copy of the document for you to work on. This is to help insure that you won’t overwrite the original after you make changes. (Of course, if you goal is to edit the document to correct typos, add more base text etc., you can easily do so. Press the Edit (pencil) button to display the original document.)

 Replacing Variables: Press the hotkey Alt-D to display the Instant Database screen. (Alternatively, press the Instant Database button from the Pathagoras Tool tab.) Next, press the Scan button near the bottom of the screen at the left. Pathagoras will scan for your bracketed variables and present them at the left. Provide replacement values at the right. When done, press the Replace button. Almost instantly, all variables will be replaced with the values you provided. Pathagoras will also as if you wish to save the variables to values pairings. If you anticipate that you will reuse the data, say Yes and follow the prompts to name and save the record. (If you are not sure if you will reuse the data, say 'yes'. There is just a miniscule amount of storage space needed for a record.)

 Boilerplate Text: Type a piece of text. We recommend your signature block. You can type it into a new document or into an existing document. (If the text already exists in a document, don't retype. Just highlight it.) Highlight the text and and then right click. (For hand-helds with no mouse, pressing and holding  the screen for about 2 seconds equals a right mouse click.) Select the Save As option and save the text into your BoilerPlate folder. That is all there is to saving any snippet to the boilerplate collection.

    To test your boilerplate collection, open a new document (or an existing one). Place the cursor at a location where you wish to insert some text. In the left (boilerplate) panel, double-click on the boilerplate clause you wish to insert. The full text of the selected boilerplate document will be inserted at the cursor location. Now imagine you have lots of clauses you may wish to insert. (Signature blocks, address blocks, certifications, entire documents of any length.) All can instantly be at your fingertips.

 Document Assembly by building blocks. Here is a good exercise to give you a flavor of Document Assembly using Pathagoras On Cloud. You can successfully assemble a document composed of several individual documents (we'll call them 'building blocks' right now, but they are just documents) even before you learn much more about the intricacies of the program. For this example, let's assemble a mini-Manual comprising a collection of Tutorial documents.

1.Left panel: Navigate to the ‘Tutorials’ folder (it’s the one that contains this document).

2.Middle panel: Check 3 or 4 documents in this folder (don’t check them all, at least not right now). clip0005

3.Tool bar: Click the Document Assembly button. (It's the computer icon with a '+' sign in the lower right. )  That moves the checked documents to the right panel. Repeat the process to add more to the assembly list. Try dragging a document to the catcher.

4.Reorganize the ‘assembly order’ by clicking the 'positioning arrows' in the list of chosen documents.

5.Check the box near the bottom of the screen that says ‘Add Page Break Between Items’. Click on one of the buttons at the bottom ('Assemble and Download' or 'Assemble in the Cloud'.)

6.TaDa!! Print, Save or Share your manual using the features in the File menu.